SVG Files

Starting with version 1.0, Otherplan supports importing .svg files. This guide introduces Otherplan’s .svg workflow, explains the advanced .svg settings, and shares tips for exporting .svg files from popular design software.

(Otherplan Classic also supports .svg files. Click here for details on Otherplan Classic’s .svg support.)

The Basics

What’s an .svg file?

Scalable Vector Graphics (.svg) is a common vector image file format. Unlike raster image files (like .jpg, .gif, and .png) that store images in grids of colored pixels, .svg files store image information as lines and shapes. As such, they can be scaled to any size and still look perfectly sharp, unlike raster images, which may look fuzzy and pixelated when scaled.

More importantly, because .svg files store shapes instead of pixels, Otherplan can turn the shapes into toolpaths, which you can then mill on the Othermill.

Why is this useful?

Simple vector drawings like .svg files are a great starting point for learning how to mill basic parts on the Othermill without learning CAD and CAM. Otherplan’s .svg file support is useful for milling two-dimensional shapes for jewelry, stencils, and other design elements, milling multi-level shapes for 2.5D projects like chocolate molds, and making simple mechanical parts.

Many common graphic design and CAD programs can edit and save .svg files. These programs are often easy to learn, and many are available for free or at a low cost. Some of our favorite programs for .svg editing are are Inkscape, Adobe Illustrator, and Sketch. There are also many free .svg files available on the web.

Using .svg files in Otherplan

How Otherplan converts .svg files to toolpaths

By themselves, .svg files are just 2D drawings, so Otherplan needs to do some work before they’re ready to mill. First, Otherplan follows a simple rule to determine where to mill: any object in an .svg file with a border or fill will be milled. Then, Otherplan combines the resulting shape with the tools you’ve selected, as well as the scaling, placement, and any advanced settings. Finally, it calculates the toolpaths that the Othermill will follow. Because .svg files require a bit of configuration, you’ll want to spend some time to learn Otherplan’s settings. Read on for all the details.

Creating your .svg file

You’ll want to start by downloading an .svg file from the web or designing the file in your design software. In order to make an .svg file that Otherplan can use, you may first need to do a small amount of formatting in the design software.

Otherplan looks at lines and filled areas to determine the inside and the outside of a shape. Otherplan will mill within fills by default. Otherplan will recognize fills of any color, including white. Make sure to check that empty areas are filled or made transparent the way you want them. Sometimes it can be helpful to set the background color in your design software to something other than white to clarify which areas are transparent and which are filled.

For example, if your .svg looks like this:

FilledGear-1

It will render in Otherplan like this:

FilledGearOtherplan

This gear has a border on the outside, but the inside of the gear is transparent.

OutlineGear

Here’s how it loads in Otherplan:

OutlineGearOtherplan

Note: the red lines in both screenshots are Unmillable Area Warnings indicating regions where the milling tools won’t be able to reach. In the case of the second image, the warning is shown because the border of the shape is too thin to be milled with the selected tools.

Another important thing to think about as you’re creating your .svg is stroke (line) thickness. Since you’ll be milling a physical object, using a stroke thickness that corresponds to the width of the tool you want to use is important. If the stroke thickness of your lines or borders are thinner than the diameter of your tool, Otherplan will not be able to mill those lines.

In Inkscape, for example, go to Object > Fill and Stroke, and select the Stroke Paint tag. Make sure the Stroke Paint is set to Flat. Then, go to the next tab, Stroke Style, and set the width of your stroke to slightly wider (say, 0.001'‘) than the diameter of the tool you want to use. In the case of an engraving bit, the default stroke width works fine, but produces fine lines. If you’d like the lines to be thicker, set your stroke width accordingly. This is a nice opportunity to experiment with different tools to get the results you’d like.

Finally, if your design contains text, you’ll want to make sure to convert the text to paths. This conversion means that the text in your design will be converted to shapes that Otherplan can open. In general, text is a reference to a font and is not a path that Otherplan can follow. Graphics tools usually have an easy way to convert text to paths; for example, in Inkscape, it’s Path > Object to Path or Path > Stroke to Path. In Illustrator, you can convert text to outlines when you’re saving the .svg file.

Once your design is ready, save it as an .svg file.

Basic .svg file setup in Otherplan

To open an .svg file in Otherplan, click File > Open or the Open Files button. When the file loads, a new plan configuration panel will appear on the right side of the Otherplan window. In the configuration panel, you’ll see a number of options:

SVGConfig

Placement

Expand the Placement panel and modify the X, Y, and Z values to manually shift your .svg within or on your material. The rotation field rotates the .svg file counterclockwise with respect to the center of the .svg.

Scale

Change the value in the Scale field to enlarge or shrink the .svg file relative to the material. If the file is larger than the material, Otherplan will automatically shrink .svg files to fit within the size of your material.

Parts to Mill

Otherplan offers two different toolpath options when milling .svg files:

  • If Engraving is selected, Otherplan will mill filled areas and strokes to the depth specified in the Engraving Depth setting (see below).
  • If Cutout is selected, Otherplan will use the outermost shape as the outline for your project and mill all the way around it, all the way through the material, using the thickness (Z) that has been set for the material.

Engraving Depth

If Engraving is selected (see above), this value is the depth to which the .svg will be milled. This setting does not affect Cutout toolpaths. The shallowest engraving depth that can be set is 0.001” or 0.025 mm)

Milling Tools

Select up to three tools to be used when milling the .svg file. With multiple tools selected, Otherplan will start with the smallest tool, milling details, before milling with the larger tools. Otherplan always uses the largest tool for the cutout, so this ordering reduces the number of tool changes required when using both the engraving and cutout toolpaths.

Milling .svg files will use the speeds and feeds defined for the tool. If you are milling a material other than FR-1, you will need to define custom feeds and speeds for best results.

Advanced .svg file setup in Otherplan

In addition to the settings above, clicking Advanced will display a few additional options:

SVGAdvanced

Invert

For the Engraving toolpath, the Invert setting makes it possible to mill the unfilled .svg file instead of the filled areas. This can be useful for projects like stamps where the milled part should be the opposite of the design. Invert has three options:

  • No: the filled areas will be engraved. This is the default.
  • Yes, within cutout: the unfilled areas inside of the outer cutout shape will be milled. The filled areas will not be milled.
  • Yes, everywhere: all unfilled areas on the material will be milled, including areas outside the cutout. The filled areas will not be milled.

Cutout placement

The Cutout toolpath will cut the outermost shape all the way through the entire thickness of your material. It can make a big difference if you cut on the inside of the line, the outside of the line, or right down the middle of the line. With this setting, you can choose where exactly the Cutout toolpath will be milled. Cutout Placement has three settings (see illustration below):

  • Outside: the Cutout toolpath will mill outside the line that defines the of the outermost shape in your design. This is the default.
  • Center: the Cutout toolpath will mill on top of the line that defines the outermost shape in your design.
  • Inside: The Cutout toolpath will mill along the inside of the line that defines the outermost shape in your design.

In this diagram, the gray box represents the design. The three circles show where the tool would mill depending on the cutout placement setting: SVG Cutout Placement Illustration

Scale from

One important factor to consider when using .svg files is your document size. Sometimes called “page size” or “artboard size,” document size refers to the dimensions of the virtual canvas in the .svg file that contains your design. The “Scale from” setting in Otherplan allows you to control whether Otherplan takes the document size into consideration when placing and scaling your .svg file when it gets imported.

  • Document contents: If you choose this option, Otherplan will place the contents of the .svg file (the lines and shapes in the file) in the lower-left corner of the material. If the contents of the .svg file are larger than the material you have set in Otherplan, the .svg will be scaled down to fit your material. The document size will be disregarded.
  • Document size: Otherplan will place the lower-left corner of the .svg document in the lower-left corner of the material. If your design is offset from the edge of your document, it will be offset from the edge of material in Otherplan by the same amount. If the document size of your .svg is larger than the material you have set in Otherplan, the entire document will be scaled down to fit.

Note: When the Document Size option is selected in Otherplan, you can create .svg files that have the same dimensions as the material you want to mill your design into. When you match the document size of your .svg to the dimensions of your material, you can precisely locate your design within the .svg and import into Otherplan without having to make any adjustments to your imported design before milling.

Tips and tricks

Otherplan makes it easy to adjust your files on the fly. You can adjust the .svg in your design program, and then click the Refresh button on the plan panel to update the Otherplan with your changes.

Refresh Button Refresh button

In order to cut out shapes within shapes, use a filled shape and what’s known as a Boolean operation in your graphics program to join the two shapes and remove fill where they overlap. For example, in Inkscape, create a filled shape with your desired cutout (here we used a filled gear with a circle in the middle with no fill). We then used the Path > Combine tool to make the gear one combined shape.

FilledCombinedGear

Notice that once FilledCombinedGear.svg is imported, we inverted it, then selected both “Engraving” and “Cutout” to the outline shape and the inside cutout to render, so it cuts the whole gear shape. The center of the gear will be engraved out, rather than cut as an outline.

FilledCombinedOtherplan

If you wish to mill from a design in a .jpg or .png image, you’ll need to convert it to a vector image first. To do this, use the image trace feature in your design software.

Tips for specific vector graphics programs

While every design software is different, we’ve collected some tips and tricks for exporting Otherplan-compatible .svg files from popular programs. If you need assistance with a specific file or are having trouble with another program, please contact us at support@othermachine.co, and we will do our best to help.

Inkscape

Inkscape is a popular free vector graphics editor. It is open source and runs on Windows, Mac, and Linux operating systems. Inkscape uses .svg as its default file format, so Inkscape .svg files should open directly in Otherplan.

Adobe Illustrator

Adobe Illustrator is a commercial vector graphics editor popular among professional designers. It is part of Adobe’s Creative Cloud suite, and runs on Windows and Mac operating systems. It’s easy to save Illustrator documents as .svg files. To do so, follow these steps:

  • With your document open, click File > Save As.
  • In the Format drop-down box, select “SVG (svg)”.
  • Give the file a name and click Save.
  • In the SVG Options window that appears, select the following options:

    • SVG Profiles: SVG 1.1
    • Type: Convert to outline
  • Click OK to save the file.

Sketch

Sketch is a popular vector editing and design app for the Mac. From a Sketch document, it is simple to export individual items as .svg files. To do so, follow these steps:

  • With your document open, click on the item, artboard, of items you would like to export.
  • Expand the Export panel. If you don’t already have export settings configured, it will be labeled “Make Exportable.”
  • In the Format drop-down box, select SVG. (If more than one set of export settings is shown, you can ignore or delete the additional rows.)
  • Click the Export button.
  • Give the file a name, and click Save.