Tool Library

Otherplan Tool Library Window

Starting in version 0.32, Otherplan has included support for custom tools. This guide covers the basics of adding and removing custom tools, setting custom speeds and feeds, and importing/exporting your tool library.

The Basics

What is the Otherplan Tool Library?

The Otherplan Tool Library is Otherplan’s database of custom tools. You can use the Tool Library to add new tools, edit tool settings, and import or export your entire tool library.

Why would I want to add tools?

Although Otherplan comes configured with all of OMC’s standard tools, there is an entire universe of milling tools in the world. You might prefer to use metric tools, tools from other suppliers, or tools with different geometry. Or, you might want to set custom speeds and feeds for a tool (i.e. if you purchase tools from an alternative manufacturer.) Adding a tool to Otherplan’s Tool Library makes this easy.

Once you’ve added a new tool, it will be available in tool selectors throughout Otherplan. In particular, the tool will be an option during the tool change process, and it will be available for use on PCB, SVG, and G-code plans.

Otherplan uses your tool definitions in two key ways: to create toolpaths and to calculate the 3D preview that account for the shape of the tool.

What kinds of tools can I add to the Tool Library?

Currently, Otherplan supports custom Flat End Mills and Engraving Bits. Otherplan does not yet support Ball End Mills, Drill Bits, or other types of tools.

Otherplan supports tools defined using either millimeters or inches.

What should I do if I’d like to use a type of tool that isn’t supported by the Tool Library?

As Otherplan is only able to create toolpaths for flat end mills and engraving bits, these are the only types of tools supported by the Tool Library.

If you’re using G-code files, there is a workaround to support other types of tools (ball end mills, chamfer bits, and so on). Simply select “flat end mill” for these tools, and give the tool an appropriate name. Then, make sure to select this tool for the appropriate toolpath in your G-code plan configuration panel. Using custom tools with imported G-code offers some advantages: your custom tools will be used for generating a 3D preview that more closely matches your design, and tool change prompts will reflect any custom tools you’ve selected for the job.

Keep in mind that using custom tools in this way for G-code files will not change your motion plan, since you’ve already accounted for tool size and speeds and feeds as part of the CAM process. However, the 3D preview will be calculated based on the shape of a flat end mill, and will not match the final milled part.

How does Otherplan set speeds and feeds for custom tools?

When milling a PCB with a custom tool, Otherplan calculates speeds and feeds based on the settings used by the default tools. You can also specify speeds and feeds for custom tools. If using material other than FR-1, custom speeds and feeds will be necessary for best results. Finally, keep in mind that tool characteristics differ between manufacturers, so if you are using tools from a source other than OMC, custom speeds and feeds may be necessary.

Managing your Tool Library

How do I open the Tool Library?

With Otherplan open, click File > Tool Library. You can also use a keyboard shortcut: Control + T on Windows and Command + T on Mac.

How do I add a tool?

To add a new tool, follow these steps:

  • If the Tool Library isn’t already open, click File > Tool Library to open it.
  • Click the “Add” button.
  • Enter a name for the tool.
  • Select the tool type. Currently, Otherplan supports Flat End Mills and Engraving Bits.
  • Enter the tool’s dimensions.

    • For Flat End Mills, set the diameter of the tool.
    • For Engraving Bits, set the angle of the tool and the tip diameter.
    • Note: You can enter tools in either Metric or Imperial units. To switch units, click View > Show Units in Inches or Show Units in Millimeters.
  • Optional: Enter custom speeds and feeds for the tool.

    • Click Feeds & Speeds to show the Speeds and Feeds settings.
    • Set the appropriate speeds and feeds settings. Please read the Speeds and Feeds guide for information on how to configure these settings.

The new tool will automatically save and be available to select elsewhere in Otherplan.

Adding an End Mill to the Tool Library Adding an End Mill to the Tool Library

Adding an Engraving Bit to the Tool Library Adding an Engraving Bit to the Tool Library

How do I remove a tool?

To remove a tool, follow these steps:

  • If the Tool Library isn’t already open, click File > Tool Library to open it.
  • In the tool list, select the tool you wish to remove.
  • Click the Remove button.

How do I export my tool library?

Otherplan’s Tool Library allows you to export your entire library to a file. This makes it possible to share your tool library with others, or to back up your tool definitions. To export your library, follow these steps:

  • If the Tool Library isn’t already open, click File > Tool Library to open it.
  • Click the Export button.
  • Navigate to the location where you’d like to save the tool library and give it a name.
  • Click Save.

Otherplan will save a .json file containing all of the tools in your library.

How do I import a saved tool library?

To import an exported Otherplan Tool Library, please follow these steps:

  • If the Tool Library isn’t already open, click File > Tool Library to open it.
  • Click the Import button.
  • Find a tool library export file, with a .json file extension.
  • Click Open.

Otherplan will add all of the tools in the imported tool library file to your tool library.

Note: if you attempt to import a tool that already exists in your tool library, the definition will not be updated.